Вопрос по информатике:
Напишите программу в ТУРБО ПАСКАЛЕ
Введите с клавиатуры переменные c и d. Если 0<c<d, то нарисуйте квадрат со стороной 2d. Иначе нарисуйте отрезок с концами в точках (c,c) и (d,d).
- 17.03.2018 03:12
- Информатика
- remove_red_eye 2223
- thumb_up 25
Ответы и объяснения 1
Uses Graph; { Подключаем модуль }
var
c,d,Gd,Gm:integer;
k:real;
begin
Writeln('10<=c<=460; 10<=d<=230');
Write('Задайте c в пределах от 10 до 460: ');Read(c);
if (c460) then Writeln('Неверное значение!')
else begin
Write('Задайте d в пределах от 10 до 230: '); Readln(d);
if (d230) then Writeln('Неверное значение!')
else begin
Gd := Detect;
InitGraph(Gd, Gm, 'Y:\tp7\bgi'); { Инициализируем графический режим }
SetColor(4);
k:=GetMaxX/GetMaxY; { Коэффициент искажений по осям }
if c
Readln;
CloseGraph
end
end
end.
- 18.03.2018 18:09
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.