Вопрос по информатике:
80 БАЛЛОВ!!!Помогите Паскаль!!!Нужно составить программу которая проверяла является ли простым числом,введенное с клавиатуры числом
- 01.08.2015 15:05
- Информатика
- remove_red_eye 16883
- thumb_up 46
Ответы и объяснения 1
Program zhn;
var
n,i,sum:integer;
begin
write('Введите значение: ');
readln(n);
for i:=1 to n do begin
if n mod i = 0 then sum:=sum+1;
end;
if sum = 2 then writeln('Число ',n,' является простым.')
else writeln('Число ',n,' НЕ является простым.');
end.
- 02.08.2015 15:02
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.