Вопрос по информатике:
Написать программу нахождения минимального элемента и его номера в целочисленном массиве. Элементы массива заданы случайным образом из промежутка от -10 до 45
на С++,пожалуйста.
- 02.06.2018 05:08
- Информатика
- remove_red_eye 8802
- thumb_up 12
Ответы и объяснения 1
#include
#include
using namespace std;
int main()
{
int n, i, k;
cout << "Kolichestvo chisel = ";
cin >> n;
srand(time(0));
int *a = new int[n];
for (int i = 0; i < n; i++)
{
a[i] = rand() % 56 - 10;
cout << a[i] << " ";
}
int min = a[0];
for (i = 0; i
min = a[i];
k = i;
}
cout << endl << endl;
cout << "Min = " << min << endl << "i = " << k << endl;
system("pause");
return 0;
}
- 03.06.2018 20:06
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.