Вопрос по информатике:
Помогите, пожалуйста, с паскалем!!!!!!!!!!!!!!!!!!!!!!
Входные данные
Вводится натуральное число x.
Выходные данные
Выведите сумму цифр числа x.
Примеры
входные данные
123
выходные данные
6
входные данные
102
выходные данные
3
- 21.05.2018 06:09
- Информатика
- remove_red_eye 13121
- thumb_up 25
Ответы и объяснения 1
Var
x,s:integer;
begin
write('x=');
readln(x);
while x>0 do
begin
s:=s+(x mod 10);
x:= x div 10;
end;
writeln('s=',s);
end.
- 22.05.2018 06:41
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.