Вопрос по информатике:
Набрать текст программы и отладить ее работу в среде Турбо Паскаль.
Подобрать тестовые данные. Протестировать.
Задачка:
Дана кривая, заданная уравнением y=x2+c и прямая y=kx+b. Определить, сколько общих точек имеют эти прямые, и найти их координаты.
- 22.07.2017 23:12
- Информатика
- remove_red_eye 11695
- thumb_up 50
Ответы и объяснения 1
Сначала надо найти аналитическое решение задачи.
Определить координаты точек пересечения двух функций - это совместно решить уравнения, описывающего функции.
Теперь можно составить программу, предусмотрев в ней анализ случаев D0.
uses Crt;
var
k,b,c,x1,x2,y1,y2,d:real;
begin
ClrScr;
Write('Введите через пробел c,k,b: '); Read(c,k,b);
d:=sqr(k)-4*(c-b);
if d<0 then Writeln('Точек пересечения нет')
else
if d=0 then begin
x1:=k/2; y1:=k*x1+b;
Writeln('Координаты точки пересечения (',x1:0:4,',',y1:0:4,')')
end
else begin
d:=sqrt(d);
x1:=(k-d)/2; y1:=k*x1+b;
x2:=(k+d)/2; y2:=k*x2+b;
Writeln('Координаты точек пересечения:');
Writeln('(',x1:0:4,',',y1:0:4,'), (',x2:0:4,',',y2:0:4,')')
end;
ReadKey
end.
Тестовые решения:
Введите через пробел c,k,b: -2 1 1
Координаты точек пересечения:
(-1.3028,-0.3028), (2.3028,3.3028)
Введите через пробел c,k,b: 1 3 -5
Точек пересечения нет
Введите через пробел c,k,b: 12 6 3
Координаты точки пересечения (3.0000,21.0000)
- 23.07.2017 22:25
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.