Вопрос по информатике:
Дано сначала число n, а затем n натуральных чисел, не превосходящих 100. Выведите на экран в порядке возрастания только те из них, которые встречаются в данной последовательности ровно один раз.
ВХОДНЫЕ ДАННЫЕ
В первой строке вводится одно число n — натуральное, не превосходящее 10000.
Во второй строке вводятся n натуральных чисел, не превосходящих 100.
ВЫХОДНЫЕ ДАННЫЕ
Выведите в порядке возрастания те из них, которые встречаются в последовательности ровно один раз.
- 15.07.2015 09:04
- Информатика
- remove_red_eye 5175
- thumb_up 42
Ответы и объяснения 1
Pascal ABC.net
Var A:array[1..100]of byte;
B:array[1..100]of integer;
N,i:integer;
Begin
Read(N);
For i:= 1 to N do
Begin
Read(A[i]);
B[A[i]]:=B[A[i]]+1;
End;
For i:= 1 to 100 do
if B[i]=1 then Write(i,' ')
End.
Чтоб каждое число в своей строке выводилось, замени Write(i,' ') на WriteLn(i)
- 16.07.2015 05:51
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.