Вопрос по информатике:
Составить программу в СИ:
1) Составить программу, проверяющую, является ли заданное натуральное число совершенным, то есть равным сумме своих положительных делителей, кроме самого этого числа.
2) Напечатать числа в виде следующей таблицы:
5 5 5 5 5
6 6 6 6
7 7 7
8 8
9
- 11.08.2016 16:34
- Информатика
- remove_red_eye 10538
- thumb_up 6
Ответы и объяснения 1
1. for( s = 0, i = 2; i < n; i++ ) if (n % i == 0) s += i;
if (s == n) совершенное.
2. printf( "5 5 5 5 5\n6 6 6 6\n7 7 7\n8 8\n9\n" );
- 12.08.2016 20:49
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.