Вопрос по информатике:
Ребят,помогите,ничего вообще не понимаю...((Что вообще за модуль,содержащий процедуру..нужно написать программу)если можно с объяснениями)
Написать модуль,содержащий процедуру нахождения минимальной цифры натурального числа. Привести пример использования данного модуля.(в Паскале)
- 11.06.2017 08:55
- Информатика
- remove_red_eye 14861
- thumb_up 8
Ответы и объяснения 1
Текст модуля (Free Pascal):
unit MyLib;
interface
procedure MinDigit(n:longint;var md:byte);
implementation
procedure MinDigit(n:longint;var md:byte);
var
d:byte;
begin
md:=10;
while n>0 do begin
d:=n mod 10;
if d
end
end;
begin
end.
Тестовая программа:
uses
Crt, MyLib;
var
p:byte;
begin
ClrScr;
MinDigit(45134,p);
Writeln('p=',p);
ReadKey
end.
Тестовое решение:
p=1
- 12.06.2017 10:34
- thumb_up 1
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.