Вопрос по информатике:
1)Написать программу, вычисляющую сумму и среднее арифметическоепоследовательности положительных чисел, которые вводятся с клавиатуры.вид экрана:Введите числа. Для завершения последовательности нажмите ноль.45 23 15 0
введено чисел:3
сумма чисел:83
Среднее арифметическое:27.67
2)аписать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положи¬тельных чисел (длина последовательности не ограничена) . (Цикл Whil или Repeat)
Определение максимального числа последовательности
положительных чисел.
Вводите после стрелки числа. Для завершения ввода введите ноль.
-> 56
-> 75
-> 43
-> О
Максимальное число: 75.
- 21.08.2015 10:11
- Информатика
- remove_red_eye 9134
- thumb_up 44
Ответы и объяснения 2
Uses crt;
var A, B:real;
begin
writeln('45, 23, 15');
writeln('Сумма чисел:3');
A:=45+23+15; B:=45+23+15/3;
writeln('Сумма чисел=',A); write('Среднее арифметическое=',B);
end.
- 22.08.2015 07:01
- thumb_up 33
Uses crt;
var a,b,c,k:integer;
begin
a:=0; b:=0; k:=1;
repeatread(c);
k:=c; a:=a+c; inc(b);
until k=0;
write(a,' ',a/(b-1));
end.
- 23.08.2015 05:09
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.