Вопрос по информатике:
Нарисовать блок схему и составить программу , которая
1) Вводит массив из 10 чисел
2)Выбирает в этом массиве числа большие -3.5 и находит из них наименьшее
3) значение наименьшего вывести на печать
-100 , -50 , -30 , -3.7 , -3 , 0 , 2 , 3 ,20, 500.
- 26.05.2015 18:08
- Информатика
- remove_red_eye 8377
- thumb_up 35
Ответы и объяснения 1
Const
n=10;
var
a:array[1..n] of real;
i:integer;
amin:real;
begin
Writeln('Введите элементы массива');
amin:=100;
for i:=1 to n do
begin
Read(a[i]);
if a[i]>-3.5 then
if amin>a[i] then amin:=a[i]
end;
Writeln('Минимальный среди элементов, больших -3.5: ',amin:0:3)
end.
Тестовое решение:
Введите элементы массива
-100 -50 -30 -3.7 -3 0 2 3 20 500
Минимальный среди элементов, больших -3.5: -3.000
Блок-схема во вложении
- 27.05.2015 05:36
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.