Вопрос по информатике:
Составить программу, которая обеспечит ввод 15 чисел и определит сколько из них отрицательных, которые кратны 3.
- 21.11.2016 13:10
- Информатика
- remove_red_eye 12135
- thumb_up 25
Ответы и объяснения 1
begin
k:=0;
writeln('Введите 15 целых чисел:');
for i:=1 to 15 do
begin
readln(a);
if (a<0)and(a mod 3 = 0) then k:=k+1;
end;
writeln('k = ',k);
end.
Пример:
Введите 15 целых чисел:
75
-65
15
-68
28
-42
80
-76
51
-32
18
-16
-45
70
-65
k = 2
- 22.11.2016 12:19
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.