Вопрос по информатике:
1.Переменной S присвоить сумму цифр четырёхзначного числа K, вводимого с клавиатуры.
2.Проверить, есть ли среди трех заданных чисел a,b,c равные. Если есть, то возвести эти числа в квадрат, иначе, их удвоить.
3.Составить программу для вычисления an.
- 23.02.2017 13:40
- Информатика
- remove_red_eye 10832
- thumb_up 43
Ответы и объяснения 1
1) Program dasf;
var a,b,i,s: integer;
begin
Writeln('Введите четырёхзначное число');
readln(a);
For i:=1 to 4 do
begin
S:=a mod 10+s;
a:=a div 10
end;
writeln('Сумма цифр четырёхзначного числа:',s);
end.
2)Program sgsgsdfg;
var a,b,c,a1,b1,c1: real;
begin
Writeln('Введите а');
readln(a);
Writeln('Введите b');
readln(b);
Writeln('Введите c');
readln(c);
If (a=b) or (a=c) then a1:=a*a
else a1:=a*2;
If (b=a) or (b=c) then b1:=b*b
else b1:=b*2;
If (c=a) or (c=b) then c1:=c*c
else c1:=c*2;
Writeln('Полученные числа: а=',a1,' b=',b1,' c=',c1);
end.
3) Program afgsdg;
var n,a,b,i: integer;
begin;
Writeln('Введите число');
readln(a);
Writeln('Введите степень');
readln(n);
b:=a;
For i:=2 to n do
a:=a*b;
Writeln('Число ',b,' в степени ',n,' равно ',a);
end.
- 24.02.2017 16:48
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.