Вопрос по информатике:
Напишите программу, находящую сумму 2 чисел, переданных в качестве входных данных. Входные данные: На стандартный ввод передаются два целых числа a,b (0≤a,b≤9)a,b (0≤a,b≤9) Выходные данные: Передайте на стандартный вывод одно число – сумму введенных чисел. Sample Input 1: 6 2 Sample Output 1: 8 Sample Input 2: 6 1 Sample Output 2: 7
- 17.09.2017 03:25
- Информатика
- remove_red_eye 18984
- thumb_up 31
Ответы и объяснения 1
using namespace std;
int main() {
bool checkA = false;
bool checkB = false;
int a;
int b;
cin >> a >> b;
cout << "Entered nums: \n";
cout << a << "\n";
cout << b << "\n";
if(a >= 0) {
checkA = true;
cout << a <= 0 \n";
}
else {
checkA = false;
cout << a <= 0 \n -Failed \n";
}
if(b <= 9) {
checkB = true;
cout << b << " is <= 9 \n";
}
else {
checkB = false;
cout << b << " isn't <= 9 \n -Failed \n";
}
if(checkA&&checkB == true) {
int sum = a+b;
cout << "Sum is " << sum;
}
else {
cout << "\n Wrong nums";
}
}
- 18.09.2017 04:58
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.