Вопрос по информатике:
13. Для какого значения числа Z высказывание ((Z > 2)Ú(Z > 4)) →(Z > 3) будет ложным?
14. Определите значение переменной c после выполнения следующего фрагмента программы, в котором a, b и c – переменные целочисленного типа:
a := 27;
b := 13;
if b div 5 > 2
then
c := b mod 5 + a mod 3
else
c := (b + a) mod 6;
15. Определите, что будет напечатано в результате работы следующего фрагмента программы?
var n, s, d: integer;
begin
readln(d);
n := 3;
s := 57;
for i:= 2 to 5 do begin
s := s + n;
n := n + 4
end;
write(s)
end.
- 24.08.2017 16:14
- Информатика
- remove_red_eye 16999
- thumb_up 23
Ответы и объяснения 1
13. Для z = 3;
14 т.к b div 5= 2
c := (b + a) mod 6;
c:= 40 mod 6
c:= 4
15. Ничего не будет напечатано, т.к программа не будет работать:
Паскаль будет ругаться, что не объявлен идентификатор i.
Но если бы он был, то на экран бы выводилось число 93
- 25.08.2017 19:01
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.