Вопрос по информатике:
Написать программу, которая заменяет все заглавные буквы строчными, а строчные – заглавными в заданной символьной строке. (Паскаль)
- 06.11.2017 14:33
- Информатика
- remove_red_eye 10332
- thumb_up 23
Ответы и объяснения 1
Program X; //работает только для русских строк
var
i: longint;
s: string;
begin
readln(s);
for i := 1 to length(s) do
if (ord(s[i]) >= 192) and (ord(s[i]) <= 223) then
s[i] := chr(ord(s[i]) + 32)
else if (ord(s[i]) >= 224) and (ord(s[i]) <= 255) then
s[i] := chr(ord(s[i]) - 32);
writeln(s)
end.
- 07.11.2017 10:23
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.