Вопрос по информатике:
Винни Пух по поводу своего Дня рождения решил угостить своих друзей: Кролика, Пяточка, Сову и ослика Иа. В магазине он купил полкило замечательных шоколадных конфет. Но, по дороге домой, Винни останавливался три раза, и каждый раз съедал половину всех имеющихся у него конфет и еще полконфеты. Причем известно, что на каждой остановке Винни съедал целое количество конфет. Сколько конфет купил Винни Пух, если каждому его другу досталось только по одной конфете?
Для решения задачи можно использовать любую среду программирования. В ответе укажите только число без каких-либо знаков препинания, например 48
- 22.02.2018 01:53
- Информатика
- remove_red_eye 17913
- thumb_up 15
Ответы и объяснения 1
// среда программирования PascalABC
var i,x :byte;
begin
x:=4; // Так как у Вини 4 друга
for i:=3 downto 1 do // цикл с обратным отсчетом
begin
x:=x+x+1;
writeln ('до ',i,' остановки у Вини было конфет ',x); // за не надобностью эту строку можно удалить
end;
writeln (x);
end.
- 23.02.2018 13:09
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.