Вопрос по информатике:
Написать программу решения задачи на языке Паскаль:
а)Известно, что Х кг шоколадных конфет стоит А рублей, а Y кг ирисок стоит В рублей. Определить, сколько стоит 1 кг шоколадных конфет, 1 кг ирисок, а также во сколько раз шоколадные конфеты дороже ирисок.
б)Дана длина ребра куба а. Найти его объем и площадь поверхности
- 27.03.2018 22:37
- Информатика
- remove_red_eye 18864
- thumb_up 23
Ответы и объяснения 1
// Известно, что Х кг шоколадных конфет стоит А рублей,
// а Y кг ирисок стоит В рублей. Определить, сколько стоит 1 кг
// шоколадных конфет, 1 кг ирисок, а также во сколько раз шоколадные конфеты дороже ирисок.
var x,y,a,b: real;
begin
writeln('Введите массу шоколадных конфет');
readln (x);
writeln('Введите сумму потраченную на покупку шоколадных конфет');
readln (a);
writeln('Введите массу ирисок');
readln (y);
writeln('Введите сумму потраченную на покупку ирисок');
readln (b);
writeln ('килограмм шоколадных конфет стоит ',(a/x):0:2,' рублей');//(a/x):0:2 - округряем до сотых)
writeln ('килограмм ирисок стоит ',(b/y):0:2,' рублей');
Writeln ('Шоколадные конфеты дороже ирисок в ',(a/x)/(b/y):0:1,' раз');// - округляем результат до десятых
end.
//Дана длина ребра куба а. Найти его объем и площадь поверхности
Var a: real;
begin
writeln ('введите длину ребра куба');
readln (a);
while a<0 do
begin
writeln ('вы ввели не допустимое значение попробуйте еще раз');
writeln ('введите длину ребра куба');
readln (a);
end;
writeln ('площадь куба равна ',a*a*6);
writeln ('объем куба равен ',a*a*a);
end.
- 28.03.2018 02:12
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.