Вопрос по информатике:
Дано условие задачи и программа, ее решающая. Предложить набор тестов для проверки работоспособности программы.
Составить программу, печатающую значение TRUE, если указанное высказывание является истинным, и FALSE в противном случае:
1. Треугольник со сторонами a, b, c является равносторонним.
Var a, b, c : integer;
Begin
Writeln(' a, b, c? '); Readln(a, b, c);
Writeln( (a=b) and (b=c) and (a=c) )
End.
- 06.10.2017 06:22
- Информатика
- remove_red_eye 3767
- thumb_up 40
Ответы и объяснения 1
1) вводить три равных натуральных числа - треугольник равносторонний. Результат программы TRUE ⇒ программа работает корректно
2) вводить три неравных натуральных числа - треугольник не равносторонний. Результат программы FALSE ⇒ программа работает корректно
3) ввести три нуля - треугольник не существует. Результат программы TRUE ⇒ программа работает некорректно
4) вводить три равных отрицательных числа - треугольник не существует. Результат программы TRUE ⇒ программа работает некорректно
5) ввести три равных или неравных вещественных числа - треугольник существует. Результата программы нет (ошибка типов) ⇒ программа работает некорректно
- 07.10.2017 14:53
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.