Вопрос по информатике:
Требовалось написать программу вычисления факториала числа n(n!=1*2*..*n). Программист торопился и написал программу неправильно. Ниже приведен фрагмент его программы, в которой содержится 5 ошибок:
K:=1;
F:=0;
While k
F:=f*k;
K:=k+1;
Найдите ошибки. Допишите необходимые операторы и выполните программу на компьютере. (Проверка 5!=120, 6!=720).
- 16.11.2017 20:34
- Информатика
- remove_red_eye 15428
- thumb_up 40
Ответы и объяснения 1
Язык С++:
#include
using namespace std;
void main(){
int n=5, k, f=1; //f - факториал, n - число, фак-ал которого нужно вычислить
while(k<=n){
f*=k;
k++;
}
cout<<"Факториал числа "<
Pascal:
program z4;
var n, k, f: integer;
begin
write('Введите число, для которого нужно вычислить факториал : ');
readln(n);
k:=1;
f:=1;
while(k<=n)
begin
f:=f*k;
k:=k+1;
end;
writeln('Факториал равен : ', f);
end.
- 17.11.2017 13:12
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.