Вопрос по информатике:
Напишите программу, которая в последовательности целых чисел вычисляет сумму всех чисел, которые кратны 6 или 11. Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30 000.
Программа должна вывести одно число: сумму всех чисел, которые кратны 6 или 11.
- 17.10.2017 20:27
- Информатика
- remove_red_eye 19832
- thumb_up 50
Ответы и объяснения 1
Var i,sum:integer;
begin
sum:=0;
repeat
readln(i);
if (i mod 6 = 0) or (i mod 11 = 0) then
sum:=sum+i;
until(i0);
write(sum);
end.
- 18.10.2017 19:41
- thumb_up 51
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.