Вопрос по информатике:
Написать программу посчитывающую в массиве сумму элементов меньших 0 ,их количество и средее значение
- 10.08.2018 06:17
- Информатика
- remove_red_eye 12055
- thumb_up 50
Ответы и объяснения 1
У меня получилась такая программка:
uses Crt;
const n=15;
type Vec=array [1..n] of integer ;
var i, SumOtr, ColOtr: integer;
A: Vec ;
begin
ClrScr;
Randomize;
SumOtr:=0;
ColOtr:=0;
WriteLn (' Massiv A: ');
for i:=1 to n do
begin
A[i]:=-10+random(20);
if A[i]<0 then
begin
SumOtr:=SumOtr+A[i];
ColOtr:=ColOtr+1;
end;
Write (A[i]:4);
end;
WriteLn;
WriteLn('ColOtr = ', ColOtr);
WriteLn('SumOtr = ', SumOtr);
WriteLn('SredOtr = ', SumOtr/ColOtr:4:2);
ReadLn;
end.
- 11.08.2018 17:06
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.