Вопрос по информатике:
Написать программу на Паскале.
Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего. Определите в какой день он пробежит больше 20км, и в какой день суммарный пробег за все дни превысит 100км
- 01.11.2017 02:54
- Информатика
- remove_red_eye 3263
- thumb_up 7
Ответы и объяснения 1
Program abc;
var a,b,i: real;
begin
a:=10; // 10 км за день
b:=1; // счетчик дней
Repeat
a:=a+a*0.1; // +10% от пробега предыдущего
b:=b+1; // счетчик дней
Until a>20; //суммарный пробег за все дни превысит 20км
writeln ('Пробег превысил 20км. на день № ',b);
Repeat
a:=a+a*0.1; // +10% от пробега предыдущего
b:=b+1; // счетчик дней
Until a>100; //суммарный пробег за все дни превысит 100км
writeln ('Пробег превысил 100км. на день № ',b);
end.
- 02.11.2017 03:19
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.