Вопрос по информатике:
составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет среднее арифметическое нечётных чисел.
только чтобы правильно было...помогите плииз!!!!
- 07.07.2018 10:53
- Информатика
- remove_red_eye 2499
- thumb_up 98
Ответы и объяснения 1
var
a: array [1..40] of integer; //Инициализируем массив из 40 целых чисел
i, s, n: integer; //s - сумма нечетных чисел, n - счетчик нечетных элементов
begin
s:= 0;
n:= 0;
write('Исходный массив: ');
for i:= 1 to 40 do
begin
a[i]:= random(20); //Формируем элемент массива
write(a[i], ' '); //Распечатываем
if a[i] mod 2 = 1 then {если элемент нечетный, то прибавляем его значение к сумме и увеличиваем счетчик нечетных элементов на 1}
begin
s:= s + a[i];
n:= n + 1;
end;
end;
writeln;
write('Среднее арифметическое: ', s / n : 0 : 5); {Делим сумму нечетных элементов на их количество и выводим с точностью до 5 знаков после запятой}
end.
- 08.07.2018 11:33
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.