Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, оканчивающихся на 7. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).В последовательности всегда имеется число, оканчивающееся на 7. Количество чисел не превышает 100. Введённые числа не превышают 1000. Программа должна вывести одно число, минимальное число, оканчивающееся на 7.
- 06.05.2016 19:54
- Информатика
- remove_red_eye 796
- thumb_up 18
Ответы и объяснения 1
var a,min : integer;
begin
a := 5;
min := 1000;
While a 0 do
begin
readln (a);
if (a mod 10 =7) and (a < min ) then
min := a;
end;
writeln (min);
end.
- 07.05.2016 17:14
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.