Вопрос по информатике:
Помогите составить программу, которая определяет три целых числа с клавиатуры, являются ли они сторонами прямоугольного треугольника.
- 17.06.2018 12:57
- Информатика
- remove_red_eye 3963
- thumb_up 28
Ответы и объяснения 1
var
a,b,c,g : integer;
// a,b,c - стороны
begin
readln (a,b,c);
// g - находим гипотенузу (наибольшее из чисел)
if a > b then
begin
if a > c then
g := a
else
g := c
end
else
if b > c
then
g := b
else
g := c;
// Если треугольник прямоугольный, то
// сумма квадратов катетов равна квадрату гипотенузы
if (sqr (a) + sqr (b) = sqr(g))
or (sqr (a) + sqr (c) = sqr(g)) then
writeln ('Yes')
else writeln ('No');
end.
- 18.06.2018 03:21
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.