Вопрос по информатике:
Составьте программу, по которой на экран будет выведена вся таблица умножения
- 12.05.2018 23:42
- Информатика
- remove_red_eye 6783
- thumb_up 26
Ответы и объяснения 2
Var b,a:integer;
begin
for b:=1 to 10 do begin
for a:=1 to 10 do begin
writeln(a,'*',b,'=',a*b);
end;
end;
end.
получается не в виде таблицы
а в столбик
- 13.05.2018 14:16
- thumb_up 13
// F#
[]
let main argv =
let generateTable n m =
Array2D.init n m (fun i j -> (i+1) * (j+1))
let printMatrix (matrix:int[,]) =
printf " "
for i = 0 to (Array2D.length1 matrix) - 1 do
printf "%4d " (i+1)
printf "\n"
printf " "
for i = 0 to (Array2D.length1 matrix) - 1 do
printf "-----"
printf "\n"
for j = 0 to (Array2D.length2 matrix) - 1 do
printf "%2d |" (j+1)
for i = 0 to (Array2D.length1 matrix) - 1 do
printf "%4d " matrix.[i, j]
printf "\n"
printf "\n"
let inputArray = generateTable 10 10
printMatrix inputArray
System.Console.ReadKey true |> ignore
0
- 14.05.2018 08:23
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.