Вопрос по информатике:
Решить в целых числах уравнение ax + b = 0.
Входные данные
Вводятся 2 целых числа: a и b.
Выходные данные
Необходимо вывести все решения, если их число конечно, “NO” (без кавычек), если решений нет, и “INF” (без кавычек), если решений бесконечно много.
В Паскале, пожалуйста!)
- 13.09.2016 22:17
- Информатика
- remove_red_eye 12036
- thumb_up 33
Ответы и объяснения 1
Var
a,b:integer;
begin
Write('Введите a,b: '); Read(a,b);
if a0 then
if (b mod a)=0 then Writeln(-b div a) else Writeln('NO')
else
if b=0 then Writeln('INF') else Writeln('NO')
end.
- 14.09.2016 17:42
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.