Вопрос по информатике:
Составить программу в Pascal
1)в строке , введенной с клавиатуры , все буквы И заменить на %
2)из строки, введенной с клавиатуры , удалить все символы ,начиная с середины.
- 16.11.2017 01:10
- Информатика
- remove_red_eye 13996
- thumb_up 26
Ответы и объяснения 1
1)
var
s:string;
i:longint;
begin
read(s);
for i:=1 to length(s) do
if s[i]='И' then s[i]:='%';
writeln(s);
end.
2)
var
s:string;
l:longint;
begin
read(s);
l:=length(s);
delete(s, (l div 2)+1, l-(l div 2));
writeln(s);
end.
- 17.11.2017 20:55
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.