Вопрос по информатике:
Помогите пожалуйста написать программу!
Найти сумму чётных чисел в интервале от А до В ( А и В - натуральные числа, А< В).
- 20.02.2018 00:29
- Информатика
- remove_red_eye 16882
- thumb_up 44
Ответы и объяснения 2
Var a,b,i,sum: integer;
begin
write ('Введите границы интервала: ');
read (a,b);
for i:= a to b do
if i mod 2 = 0 then sum:=sum + i;
writeln ('Сумма четных чисел в интервале от А до Б = ',sum);
end.
- 21.02.2018 23:29
- thumb_up 50
uses Crt;
var a, b, temp, i, S:integer;
begin
ClrScr;
Write (' a = '); ReadLn(a);
Write (' b = '); ReadLn(b);
S:=0;
i:=a;
while i<=b do
begin
if (i mod 2 = 0) then S:=S+i;
i:=i+1;
end;
WriteLn(' S = ', S);
ReadLn;
end.
- 22.02.2018 16:54
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.