Вопрос по информатике:
Составить программу, которая спрашивает: "Кто это, кошка или собака?". В зависимости от ответа ("К" или "С"), печатает на экране: "Мяу-мяу!" или "Гав-гав!".
помогите пожалуйста, очень прошу
- 02.03.2018 21:01
- Информатика
- remove_red_eye 3328
- thumb_up 11
Ответы и объяснения 2
//Pascal
var
x:char;
begin
writeln('Кто это, кошка или собака?');
readln(x);
if x = 'К' then
writeln('Мяу-мяу!');
if x = 'C' then
writeln('Гав-гав!');
end.
- 03.03.2018 04:21
- thumb_up 41
// F#
open System;
[]
let main argv =
let rec getResult _ =
let answer = Console.ReadKey(true);
match answer.KeyChar with
| 'К' | 'к' -> "Мяу-мяу!"
| 'С' | 'с' -> "Гав-гав!"
| _ -> (getResult null)
printf "Это кошка или собака?\n"
printf "%s" (getResult null)
0
- 04.03.2018 12:57
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.