Вопрос по информатике:
Дано Х и N. Составить программу для Х в степени N на Паскале.
- 16.06.2015 10:23
- Информатика
- remove_red_eye 792
- thumb_up 32
Ответы и объяснения 2
Var x, n, res, i: integer;
begin
res:=1;
readln(x);
readln(n);
for i:= 1 to n do
res:=res*x;
writeln(x, '^', n, ' = ', res);
end.
- 17.06.2015 05:24
- thumb_up 6
О типах x и n неизвестно ничего, но по сложившейся традиции резонно предположить, что n - целое, x - вещественное. Представленная программа написана именно в таком понимании типов переменных.
var
i,n:integer;
x,p:double;
begin
Write('Введите основание (x) и показатель степени (n): ');
Read(x,n);
if x=0 then p:=0
else begin
p:=1;
for i:=1 to Abs(n) do p:=p*x;
if n<0 then p:=1/p
end;
Writeln(x,'^',n,'=',p)
end.
Тестовые решения:
Введите основание (x) и показатель степени (n): 2 30
2^30=1073741824
Введите основание (x) и показатель степени (n): -3.35 9
-3.35^9=-53137.7624927636
Введите основание (x) и показатель степени (n): 18.3 -4
18.3^-4=8.9165251950717E-06
- 18.06.2015 04:01
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.