Вопрос по информатике:
1.Составьте блок-схему алгоритма и программу вывода на экран всех четных двузначных чисел. 2.Составьте блок-схему алгоритма и программу вычисления суммы
всех трехзначных чисел кратных 4; Составьте программу вывода на экран таблицы умножения на 3
Если можете алгоритм составьте пожалуйста
- 25.08.2017 21:17
- Информатика
- remove_red_eye 16916
- thumb_up 36
Ответы и объяснения 1
1.
var n,i:integer;
mass:array[1..10000] of integer;
begin
writeln('Введите кол-во чисел');
read(n);
for i:=1 to n do
begin
write('mass[',i,']=');
read(mass[i]);
end;
writeln('Элементы массива которые четные и двухначные');
for i:=1 to n do
if (mass[i] mod 2=0) and (mass[i] div 10>0) and (mass[i] div 10<10) then write(mass[i]:4);
end.
2.
var n,i:integer;
mass:array[1..10000] of integer;
begin
writeln('Введите кол-во чисел');
read(n);
for i:=1 to n do
begin
write('mass[',i,']=');
read(mass[i]);
end;
writeln('Элементы массива которые кратны 4 и трехзначные');
for i:=1 to n do
if (mass[i] mod 4=0) and (mass[i] div 100>0) and (mass[i] div 100<10) then write(mass[i]:4);
end.
3.
var i,a,m:integer;
begin
m:=3;
for i:=1 to 10 do
writeln(i,' * ',m,' = ',i*m);
end.
- 26.08.2017 19:34
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.