Вопрос по информатике:
Минимум-Максимум.
На вход программе подается последовательность целых чисел,заканчивающаяся 0.Видитет минимальное и максимальное значение среди чисел этой последовательности,0 при этом не учитывается.При решении задачи массив использовать нельзя.
- 20.10.2017 11:00
- Информатика
- remove_red_eye 3637
- thumb_up 10
Ответы и объяснения 1
Var max, min, x:real;
begin
max:=-32001;
min:=32001;
readln(x);
while x0 do begin
if x > max then
max:=x;
if x < min then
min:=x;
readln(x);end;
write(max,min);
readln
end.
- 21.10.2017 15:34
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.