Вопрос по информатике:
Написать программу определяющую является ли окружность с радиусом r вписанной или описанной около квадрата
- 17.06.2018 19:29
- Информатика
- remove_red_eye 12447
- thumb_up 13
Ответы и объяснения 1
Var
a,r,rvp,rop:real;
begin
Write('Введите сторону квадрата и радиус окружности: ');
Readln(a,r);
rvp:=a/2; rop:=a*sqrt(2)/2;
if r
if r=rvp then Writeln('Введен радиус вписанной окружности')
else
if r
if r=rop then Writeln('Введен радиус описанной окружности')
else Writeln('Окружность расположена вне описанной')
end.
Тестовое решение:
Введите сторону квадрата и радиус окружности: 8 5
Окружность расположена между вписанной и описанной
- 18.06.2018 21:04
- thumb_up 2
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.