Вопрос по информатике:
Написать программу на языке Си
.1. Подсчитать количество прописных букв в строке.
2. Удалить из строки самое длинное слово.
- 07.06.2015 16:53
- Информатика
- remove_red_eye 7201
- thumb_up 15
Ответы и объяснения 1
Написать програму которая считывает текст с клавиатуры, находит самое длинное число и определяет, сколько раз оно встретилось в тексте.
Код C++
#include
#include
#include
#include
void main();
{clrscr();
char s[50];
char s1{}=" ";
char *p;
char *q;
char e[50];
int g,a;
cout<<"vvedite tekst:"<
p=strtok(s,s1);
while(p)
{if(*p==' ')
p=strtok(s,s1);
g=strlen(p);
cout<
*e=*p;
}
p=strtok(NULL,s1);
}
puts(e);
cout<
}
- 08.06.2015 10:42
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.