Вопрос по информатике:
Написать программу вычисления среднеарифметического последовательно вводимых целых чисел, пропуская отрицательные, с окончанием по вводу признака конца.
- 02.12.2017 15:37
- Информатика
- remove_red_eye 16839
- thumb_up 48
Ответы и объяснения 1
Var a,b,k,s:integer;
Begin
writeln ('Сколько всего будет чисел?');
readln (a);
writeln ('Вводите числа по одному через enter');
for b:=1 to a do
begin
readln (k);
if k>0 then S:=S+k;
end;
writeln(S/a);
end.
- 03.12.2017 23:29
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.