Вопрос по информатике:
Каждая бактерия делится на две в течение одной минуты. В начальный момент времени имеется одна бактерия. Составьте программу, которая рассчитывает количество бактерий на заданное вами целое значение момента времени.
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 13.06.2015 09:52
- Информатика
- remove_red_eye 14216
- thumb_up 12
Ответы и объяснения 1
Var bak:integer;
begin
readln(bak); //Вбиваем требуемое кол-во минут
/*каждую минуту кол-во бактерий увеличивается вдвое, т.к. вначале мы имеем всего 1 бактерию, то просто умножаем кол-во минут на 2 */
bak:=bak*2;
writeln(bak);
readln;
end.
- 14.06.2015 12:25
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.