Вопрос по информатике:
Напишите программу для решения следующей задачи.
Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. Найдите среднюю температуру за время наблюдения. Если количество дней, когда температура поднималась выше нуля градусов, не менее 5, выведите YES, иначе выведите NO.
Программа получает на вход количество дней, в течение которых проводилось наблюдение N (1 ≤ N ≤ 31), затем для каждого дня вводится температура.
- 03.03.2018 18:04
- Информатика
- remove_red_eye 9380
- thumb_up 38
Ответы и объяснения 1
Var N,i,k,z:integer;
s:real;
begin
s:=0;
k:=0;
repeat
write('Введите кол-во дней : ');
readln(N);
until (N>=1) and (N<=31); {проверка на верное количество дней}
for i:=1 to N do
begin
write ('Введите значение температуры в ',i,' день : ');
readln(z);
s:=s+z;
if z>0 then k:=k+1;
end;
s:=s/N;
writeln('Средняя температура = ',s);
if k>=5 then writeln('YES') else writeln('NO');
end.
- 04.03.2018 03:50
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.