Вопрос по информатике:
Написать программу на языке Pascal. Найти значение выражения для
заданного x.
1.1. 2x+5;
1.2. 3x^2+1x+7;
1.3. 3x+7;
1.4. 2x^2+7+10
Знак ^ обозначает степень числа, а в паскале записывается как Sqr(x), где x переменная.
- 13.04.2018 01:27
- Информатика
- remove_red_eye 4285
- thumb_up 24
Ответы и объяснения 2
Var x:integer;
begin
x:= ;//Сюда ввести значение.
writeln(2*x+5);
writeln(3*Sqr(x)+1*x+7);
writeln(3*x+7);
writeln(2*sqr(x)+7+10);
end.
С вводом X:
var x:integer;
begin
writeln('Введите x: ');
readln(x);
writeln(2*x+5);
writeln(3*Sqr(x)+1*x+7);
writeln(3*x+7);
writeln(2*sqr(x)+7+10);
end.
- 14.04.2018 12:18
- thumb_up 36
Var
x,i,a1,a2,a3,a4:integer;
Begin
readln(x);
a1:=2*x+5;
a2:=3*sqr(x)+x+7;
a3:=3*x+7;
a4:=2*sqr(x)+7+10;
writeln(a1);
writeln(a2);
writeln(a3);
writeln(a4);
End.
- 15.04.2018 19:42
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.