Вопрос по информатике:
Напишите программу, запрашивающую ввод с клавиатуры трех строковых величин – взаимосвязанные прилагательное, существительное и глагол, а затем выводит на экран все возможные варианты сочетаний этих слов в предложении. Слова вводит пользователь любые!!! См. пример в таблице
Входные данные Выходные данные
ОСЕННИЕ осенние листья опадают
ЛИСТЬЯ осенние опадают листья
ОПАДАЮТ листья осенние опадают
листья опадают осенние
опадают осенние листья
опадают листья осенние
- 21.11.2016 09:52
- Информатика
- remove_red_eye 7076
- thumb_up 17
Ответы и объяснения 1
Var
a,b,c:string;
begin
write('Введите прилагательное ');
readln(a);
write('Введите существительное ');
readln(b);
write('Введите глагол ');
readln(c);
begin
writeln(a,' ',b,' ',c);
writeln(a,' ',c,' ',b);
writeln(b,' ',a,' ',c);
writeln(b,' ',c,' ',a);
writeln(c,' ',a,' ',b);
writeln(c,' ',b,' ',a);
end;
end.
- 22.11.2016 14:25
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.