Вопрос по информатике:
Чему будет равно значение переменной c в результате выполнения фрагмента программы
a:=1257; c:=0;
while a>0 do begin
if a mod 2<>0 then b:=a mod 10; c:=c+b;
a:=a div 10; end;
1) 5; 2) 13; 3) 16; 4) 18.
- 25.08.2018 08:32
- Информатика
- remove_red_eye 16969
- thumb_up 10
Ответы и объяснения 1
Var a,b,c:integer;
begin
a:=1257;
c:=0;
while (a>0) do
begin
if (a mod 2 0) then
b:= a mod 10;
c:=c+b;
a:=a div 10;
end;
writeln(c);
end.
Вариант ответа: 4
- 26.08.2018 01:18
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.