Вопрос по информатике:
Составить программу вычисления суммы всех целых чисел от 0 до 100.
1 использовать цикл с предусловием.
2 использовать цикл с постусловием.
3 использовать цикл с параметром
- 19.12.2015 21:48
- Информатика
- remove_red_eye 14253
- thumb_up 36
Ответы и объяснения 1
1)
Var
i,n:integer;
begin
n:=0;
i:=0;
while i100 do begin
i:=i+1;
n:=n+i;
end;
writeln(n);
end.
2)
Var
i,n:integer;
begin
n:=0;
i:=0;
repeat
I:=i+1;
n:=n+i;
until i=100;
writeln(n);
end.
3)
Var
i,n:integer;
begin
n:=0;
i:=0;
For i:=0 to 100 do
n:=n+i;
writeln(n);
end.
- 20.12.2015 14:58
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.