Вопрос по информатике:
Даны две точки в плоской прямоугольной системе координат. Напишите программу,определяющую, которая из точек находится ближе к началу координат.
- 09.11.2017 04:45
- Информатика
- remove_red_eye 18159
- thumb_up 52
Ответы и объяснения 1
может быть так:
var x1,x2,y1,y2:integer;
a,b:real;
begin
write ('Введите x1 и x2: ');
readln (x1,x2);
write ('Введите y1 и y2: ');
readln (y1,y2);
a:=sqrt (sqr (x1) + sqr (y1));
b:=sqrt (sqr (x2) + sqr (y2));
if a>b then writeln ('1-я точка ближе')
else writeln ('2-я точка ближе');
end.
- 01.01.1970 00:00
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.