Вопрос по информатике:
Напишите программу вычисления наименьшего общего кратного следующих четырех чисел: 36 54 18 и 15. Используйте процедуру вычисления общего делителя двух чисел
- 10.04.2018 15:41
- Информатика
- remove_red_eye 3271
- thumb_up 14
Ответы и объяснения 1
Var
A:array[1..4] of integer;
i,j,R,P:integer;
function HOD(c,b:integer):integer;
begin
while cb do
if c>b
then
c:=c-b
else
b:=b-c;
HOD:=c;
end;
function HOK(c,b, RR:integer):integer;
begin
if ((c mod b=0) or (b mod c=0)) and ((c div b > 1) or (b div c > 1))
then
begin
if c>b
then
HoK:=c
else
HOK:=b;
end
else
HOK:=(c*b) div RR;
end;
begin
A[1]:=36;
A[2]:=54;
A[3]:=18;
A[4]:=15;
P:=1;
R:=HOD(A[1],A[2]);
P:=HOK(A[1], A[2], R);
for i:=3 to 4 do
begin
R:=HOD(R, A[i]);
P:=HOK(P, A[i],R);
end; writeln('HOK = ',P);
end.
- 11.04.2018 18:51
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.