Вопрос по информатике:
3. Написать программу вычисления xy, не используя функцию возведения в степень (только цикл). X,y вводятся с клавиатуры
- 05.07.2018 04:46
- Информатика
- remove_red_eye 15023
- thumb_up 36
Ответы и объяснения 2
Тривиальное решение.
var
i,r,x,y:integer;
begin
Write('Вычисление х в степени y, введите х,y: ');
Readln(x,y);
r:=x;
for i:=2 to y do r:=r*x;
Writeln('Результат: ',r)
end.
Тестовый прогон:
Вычисление х в степени y, введите х,y: 2 10
Результат: 1024
Вариант для любителей начинать циклы с единицы.
var
i,r,x,y:integer;
begin
Write('Вычисление х в степени y, введите х,y: ');
Readln(x,y);
r:=1;
for i:=1 to y do r:=r*x;
Writeln('Результат: ',r)
end.
- 07.07.2018 15:18
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.