Вопрос по информатике:
Программа получает на вход целые числа, не равные 0. Количество введенных чисел неизвестно, последовательность чисел заканчивается 0. Введенные числа по модулю не превышают 30000. Программа должна ответить на вопрос: верно ли, что максимальное из чисел превышает минимальное больше чем в 2 раза?
- 02.09.2017 09:35
- Информатика
- remove_red_eye 18049
- thumb_up 44
Ответы и объяснения 1
Begin
ReadLn(A);
Max:=A;
Min:=A;
While A0 do
Begin
ReadLn(A);
if A>Max then Max:=A;
if A
WriteLn(Max/Min > 2)
End.
- 03.09.2017 20:48
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.