Вопрос по информатике:
Напишите программу решения задачи на языке Паскаль: Даны два целых двузначных числа. Переставить местами цифры наибольшего из них. Если полученное число останется наибольшим вывести «YES», в противоположном случае вывести «NO».
- 17.09.2017 14:08
- Информатика
- remove_red_eye 2836
- thumb_up 27
Ответы и объяснения 1
Var
a,b,max,min:integer;
begin
Write('Введите два целых двухзначных числа: '); Readln(a,b);
if a>b then begin max:=a; min:=b end
else begin max:=b; min:=a end;
if (10*(max mod 10)+(max div 10))>min then Writeln('YES')
else Writeln('NO')
end.
- 18.09.2017 16:27
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.