Вопрос по информатике:
Надо написать программу на Паскале, без массивов.
Дано натуральное число. Определить, сколько раз у этого числа встречается минимальная цифра. (Например, при вводе числа 2618319, на экране должно быть "2").
- 24.03.2018 02:00
- Информатика
- remove_red_eye 7547
- thumb_up 48
Ответы и объяснения 2
Var a, k, count: integer;
begin
readln(a);
k:=a mod 10;
a:=a div 10;
count:=1;
while(a0) do begin
if(a mod 10 = k) then count+=1;
if(a mod 10 < k) then begin
k:=a mod 10;
count:=1;
end;
a:=a div 10;
end;
writeln(count);
end.
- 25.03.2018 13:45
- thumb_up 29
Var
s:string;
c:char;
i,k:integer;
begin
Write('Введите число: '); Readln(s);
c:=s[1]; k:=1;
for i:=2 to length(s) do
if s[i]=c then Inc(k)
else if s[i]
end.
Тестовое решение:
Введите число: 3141592653589793
Наименьшая цифра 1 встретилась 2 раз(а)
- 26.03.2018 04:24
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.