Вопрос по информатике:
Дано трехзначное число.Кратна ли 5 сумма его чисел.НАДО СДЕЛАТЬ ЧЕРЕЗ ПРОГРАММУ ПАСКАЛЬ(написать программу) помогите плиз
- 24.07.2018 19:55
- Информатика
- remove_red_eye 14396
- thumb_up 22
Ответы и объяснения 1
Var a, sum : integer;
begin
readln(a); - считываем данное число
sum := (a div 100) + ((a mod 100) div 10) + (a mod 10); - сумма цифр
if (sum mod 5 = 0) then writeln('yes') else writeln('no'); - проверка делимости на 5
end.
- 25.07.2018 19:58
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.