Вопрос по информатике:
составить программу
1)найти сумму всех элементов массива (1до10) random.
2)сформировать массив из положительных и отрицательных элементов от -10 до 30.найти кол-во положит и отриц элементов.найти сумму положит и произведение отриц.
- 07.12.2017 14:51
- Информатика
- remove_red_eye 3305
- thumb_up 73
Ответы и объяснения 1
var a:array[1..10] of integer;
i,s:integer;
Begin
randomize;
for i:= 1 to 10 do begin
a[i]:= random(100);
s:=s+a[i];
end;
writeln(s);
End.
var a:array[1..10] of integer;
i,mk,pk,s,p:integer;
Begin
randomize;
p:=1;
for i:= 1 to 10 do begin
a[i]:= random(30+10)-10;
if a[i]>=0 then begin
pk:=pk+1;
s:=s+a[i];
end
else begin
mk:=mk+1;
p:=p*a[i];
end;
end;
writeln(pk,s,mk,p);
End.
- 08.12.2017 12:43
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.